General Concepts

From LBSim
Jump to: navigation, search

The main window of the LBSim software, in the default state, has a central area for visualization of the simulation rendering and two side panels, at left and right. The left panel, named View, has controls for adjusting the visualization of the results. The right panel, named Info, shows some information about the current simulation. Beyond that, there is a menu bar, containing the following menus: File, Simulation, Tools and Window. The File menu groups commands related to the operations, as expected. The Simulation menu contains actions to start and stop the simulation. The Tools menu allows the user to open the dialogs of the LBSim. Finnaly, the Window menu offers some additional tools to the user.

Main screen.png

The developed program is dynamic by concept. In most of the cases, you can update the parameter value during the execution of the simulation and this change will be immediately considered by the software. The textfields wait for the ENTER key to execute their value update. So, to change the relaxation parameter, for instance, you put the focus in the appropriate textfield, change the value at it and press the ENTER key.

Another point that deserves to comment is the values: except in the physics panel, all values presented in program are nondimensional. This means that all values are based on the lattice units: the length is given in cells; the time, in timesteps.

Previous Next